Tuesday, April 19, 2016

DELL Switch : Configure HOSTNAME, VLAN, IP and TRUNK

1.Create VLAN and VLAN definition on DELL OpenManage

  • T - The interface is a member of a VLAN. All packets forwarded by the interface are tagged. The packets contain VLAN information.
  • U - The interface is a VLAN member. Packets forwarded by the interface are untagged.
  • F - The interface is denied membership to a VLAN.
  • Blank - The interface is not a VLAN member. Packets associated with the interface are not forwarded.  
dell-switch#configure terminal
dell-switch(config)#vlan 20
dell-switch(config-vlan20)#exit
dell-switch#copy running-config startup-config
dell-switch#show vlan


2.To assign port to spesific VLAN

dell-switch#configure terminal
dell-switch#vlan id 20
dell-switch(config-vlan20)#interface Gigabitethernet 1/0/16
dell-switch(config-if-Gi1/0/16)#switchport access vlan 20
dell-switch(config)#show vlan id 20
dell-switch#copy running-config startup-config
*example vlan id 20

2.To disable IP to interface default VLAN

dell-switch(config)# interface vlan 1
dell-switch(config-if)# no ip address
dell-switch(config-if)# exit

3.To assign IP to interface VLAN

dell-switch(config)# interface vlan 50
dell-switch(config-if)# ip address 10.XX.XX.XX 255.255.255.0
dell-switch(config-if)# exit

4.To assign trunk port and attach to VLAN 

dell-switc(config)# interface gigabitethernet 1/0/24
dell-switc(conf-if-eth1/1/1)# switchport mode trunk
dell-switc(conf-if-eth1/1/1)# switchport trunk native vlan 50
dell-switc(conf-if-eth1/1/1)# switchport trunk allowed vlan all

5.To enable HTTPS

dell-switch#configure terminal
dell-switch(config)#crypto certificate 1 generate
dell-switch(config-crypto-cert)#key-generate <512-2048>
dell-switch(config-crypto-cert)#exit
dell-switch(config)#ip http secure-server
dell-switch#copy running-config startup-config

6.To disable HTTPS

dell-switch(config)# no ip http server

7.To enable SSH

dell-switch#configure terminal
dell-switch(config)#crypto key generate rsa
dell-switch(config)#ip ssh server
dell-switch#copy running-config startup-config

source :

  1. https://www.dell.com/downloads/global/products/pwcnt/en/app_note_4.pdf
  2. http://www.dell.com/Support/Article/us/en/04/HOW10690
  3. http://en.community.dell.com/support-forums/network-switches/f/866/t/19495197

Related Posts:

0 comments:

Post a Comment